Platform outage
Incident Report for Sparkcentral
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 23, 2019 - 18:20 PDT
Investigating
Customers in the US may be unable to log in to the platform. We are investigating the issue with urgency and will resolve it ASAP.
Posted 6 months ago. Apr 23, 2019 - 18:15 PDT
This incident affected: Agent Desktop.