EU Customers - Error with X/Twitter outbound direct messages
Incident Report for Sparkcentral
Resolved
The incident has been resolved.
Posted Mar 14, 2024 - 22:54 PDT
Investigating
We are experiencing issues with sending direct messages through X/Twitter in Sparkcentral EU. Our team is currently investigating. Thank you in advance for your understanding.
Posted Mar 14, 2024 - 21:53 PDT
This incident affected: Communication Channels (Twitter).