FB Messenger - Duplicate Outbound Messages (EU and US Platform)
Incident Report for Sparkcentral
Resolved
This incident has been resolved.
Posted 6 months ago. May 07, 2019 - 00:51 PDT
Monitoring
A Facebook problem was escalated to the Facebook engineering team . Facebook was reporting an error on sending messages when they actually succeeded, which caused Sparkcentral to retry sending the message, resulting in the same message being sent multiple times. It seems Facebook has resolved the issue based on our testing but we have not received final confirmation from Facebook. We will continue to monitor for Facebook confirmation but at this time the problem appears resolved.
Posted 6 months ago. May 06, 2019 - 18:08 PDT
Identified
We've identified that this issue is due to a bug on the Facebook platform. We are monitoring Facebook's progress on fixing this bug. In the meantime, we are exploring possible workarounds.
Posted 6 months ago. May 06, 2019 - 17:38 PDT
Update
We are continuing to investigate this issue.
Posted 6 months ago. May 06, 2019 - 16:53 PDT
Investigating
We are receiving an error message from Facebook when trying to send an outbound private message. Our system then tries to resend the message, causing duplicate private messages to be sent to the end user. We are currently investigating this issue.
Posted 6 months ago. May 06, 2019 - 16:51 PDT
This incident affected: Communication Channels (Facebook).